Использование UberDrupal, Ubercart установка профиля

drupal ubercart

Когда мы установливаем профиль, мы даем конкретные указания Drupal установливать дополнительные модули, какой язык использовать, какие темы включить, или то какие настройки использовать после установки. Это очень мощный инструмент, с большим потенциалом, так как он позволяет разработчикам создавать предопределенные пакеты Drupal, созданные для конкретных целей, например блоги, галереи изображений, журналы, или интернет-магазины. Единственным недостатком этой процедуры является то, что профили не полностью автоматизированы, вам все равно придется сначала загрузить все необходимые модули, а затем запустить установку профиля.

Drupal Ubercart установка.png

Для автоматизации установки используется сборка Друпала с модулями - профайл UberDrupal. Это автоматически устанавливает все основные Ubercart и Drupal необходимые модули, которые я упоминал ранее. Она также позволяет некоторые основные предварительной конфигурации и создает магазин с настройками по умолчанию. Если вы хотите использовать эту установку профиль, вы должны сначала загрузить все необходимые модули Drupal и все Ubercart модулей, и поместить их в  папку sites/all/modules. Тогда, скачать UberDrupal от http://drupal.org/project/uberdrupal, и положить его в каталог профилей. Теперь, когда вы запустите программу установки вы увидите два варианта Выберите установки профиля: Drupal или UberDrupal. Выбор Второй вариант позволяет UberDrupal профиль установки.

Drupal Ubercart загрузка профайла

 

Комментарии

Добавить комментарий

Войти, используя Loginza Google Account Yandex Mail.ru Vkontakte Facebook

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Строки и параграфы переносятся автоматически.

запускаю программу установки,

запускаю программу установки, вижу два варианта: Drupal и UberDrupal. Выбираю  UberDrupal, а он не устанавливается. Выдается ошибка: Warning: require_once(./profiles/uberdrupal/uberdrupal.profile) [function.require-once]: failed to open stream: No such file or directory in Q:\home\ecostyle\www\install.php on line 94

Fatal error: require_once() [function.require]: Failed opening required './profiles/uberdrupal/uberdrupal.profile' (include_path='.;/usr/local/php5/PEAR') in Q:\home\ecostyle\www\install.php on line 94

 Что делать? 

 

Статья немного устарела,

Статья немного устарела, UberDrupal видимо совсем забросили. Если хотите готовый магазин на Друпал используйте этот инсталяционный профайл:

Commerce Kickstart

http://drupal.org/project/commerce_kickstart