Минимальные требования для Ubercart установки

drupal ubercart

Для того, чтобы успешно установить и использовать Ubercart, система должна отвечать следующим требованиям:

  • Операционная система Windows, Mac OS X, Linux, Unix, BSD, Solaris или
  • Веб-сервер Apache 1.2 или Apache 2.x, Microsoft IIS 6 или 7, Lighttpd
  • База данных MySQL 4.1 или MySQL 5.0, PostgreSQL 7,4
  • PHP 4.3.5.  (PHP 5.2.x рекомендуется)

Теперь, давайте разрабатывать немного больше по вышеуказанным требованиям:

Операционная система

Drupal прекрасно работает почти в каждой операционной системы. На самом деле, вы можете перенести ваши Drupal установки с одной операционной системы в другую в течение нескольких минут. Все, что вам нужно сделать, это перемещение файлов и баз данных без изменения любых файлов конфигурации. Например, вы можете установить Drupal на локальном Windows или Mac компьютера, сделать все настройки там, а затем загрузить его на сервер Linux.

Веб-сервер

Веб-сервер - это программное обеспечение, которое принимает HTTP-запросы от браузеров и предоставляет веб-страницы для пользователей нашего сайта. Наиболее популярный веб-сервер Apache и мы будем использовать его для нашей установки. Это безопасный, расширяемый сервер, который быстро и легко настроить. Если вы не специалист в другом веб-сервере, нет никаких оснований выбирать любой другой веб-сервер, потому что большинство из имеющейся возможностей есть в Apache.

База данных

Цель базы данных хранение, организация, управление и получение всех данных на нашем сайте в структурированном виде. Когда речь идет о данных, мы имеем в виду не только содержание, что вы поместили на ваших страницах, но и ту часть информации, что Drupal использует для всех его функций. В моих уроках, мы будем использовать MySQL в качестве базы данных. Сегодня это СУБД № 1 с открытым кодом, ее используют в миллионах веб-сайтов и приложений, от небольших личных веб-страниц до корпоративных систем с миллионами пользователей. После установки Друпала базы данных MySQL содержит около 50 таблиц и каждый новый установленный модуль создает одну или несколько новых таблиц. Если вы проверите базу данных после установки Ubercart, вы обнаружите там около 100 таблиц. Эти таблицы содержат данные, такие как страницы, продукты, изображения, категории, заказы, платежи, кэшированная информация для ваших страниц, тематизации, комментарии от посетителей, меню, информация о пользователе и так далее.

PHP

PHP - это скриптовый язык, который идеально подходит для веб-разработки. Он начинался как небольшой личный проект, но вскоре стал очень популярным языком сценариев. Drupal написан на PHP.

Основные требования PHP являются:

  • PHP требования к памяти: 16 МБ вполне достаточно для многих сайтов, однако, 64 МБ, рекомендуется для более сложных сайтов.
  • GD2 библиотека: это библиотека обработки изображений для PHP. Ubercart требует эту библиотеку, так что если мы хотим приложить изображение к нашей продукции, она должна быть установлена.
  • Register Globals: На самом деле это остаточная функция PHP, но некоторые хостинг-провайдеры со старыми системами все еще используют его. Это представляет опасность, поэтому он должен быть отключен для установки Drupal.
  • Безопасный режим: Drupal 6 не поддерживает безопасный режим PHP (safe mode), потому что он вызывает проблемы, связанные с загрузкой файлов, так что и он должен быть отключен.

Добавить комментарий

Войти, используя Loginza Google Account Yandex Mail.ru Vkontakte Facebook

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Строки и параграфы переносятся автоматически.