Модуль Backup and Migrate

ВложениеРазмер
Image icon backup_and_migrate_7.x-2.7.jpg62 КБ
Image icon backup_and_migrate_7.x-2.4.jpg61.46 КБ

Раздел форума: 

Здравствуйте, Иван!

У меня такой вопрос к Вам, точнее проблема.

Есть на хостинге сайт.

Как-то обновлял модули, а именно модуль Backup and Migrate (с версии 2.4 на 2.7).

Забыл перевести сайт в режим обслуживания, а обновление уже запустил.

Пришлось прервать обновление, в результате чего модуль встал криво, то есть резервную копию сайта не делает,

пишет ошибку (нет выбора базы, см. рис. и сравните как должно быть). Пришлось вернуться к старой версии модуля, который замечательно работает. К слову, новый модуль на Денвере работает в штатном режиме, из чего делаю вывод, что дело в прерывании установки модуля.

Как можно это исправить? Или дождаться выхода следующей версии модуля?

С уважением. Дмитрий.

Добавить комментарий

Войти, используя Loginza Google Account Yandex Mail.ru Vkontakte Facebook

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Строки и параграфы переносятся автоматически.
Прикрепить
Максимальный размер файла: 64 МБ.
Разрешённые типы файлов: txt doc docx rar zip xls xlsx pdf odf odt jpg jpeg gif png psd rtf.

Сделайте перед всеми

Сделайте перед всеми эксперментами полный бекап сайта. Если backup and migrate не работает, тогда через phpmyadmin.

Попробуйте поставить старую версию модуля и запусть update.php, по идеи должен удалить, что установлено модулем backup and migrate 2.7.

Если все совсем плохо и 2.7 все равно не работает, тогда идем в файл .install модуля и смотрим чем отличается  2.4 версия от 2.7, если есть отличия, то можно вручную досоздать в БД нужные поля.

Но всегда проще отключить модуль backup and migrate и удалить его полностью и потом уже установить новую версию.

Спасибо за ответ, буду

Спасибо за ответ, буду пробовать. Странное дело, отключаю новый модуль, удаляю его, ставлю старый - работает.

Отключаю старый модуль, удаляю его, ставлю новый - та же проблема. И так по кругу. Попробую вручную в базе поискать, в чем там дело.